Maschine Mikro MK3 problems


So it seems that my personal quest for groove is also the quest for a usable controller.
I started out with the Launchpad X, cause I thought I wanted more than 16 pads to also be able to play melodies. I didn’t like the sensitivity (even though I changed it to the most sensitive level), so I returned it and got a Maschine Mikro instead.

I had some issues with one pad that sometimes got stuck - either it stayed lit or wouldn’t trigger.
The store was nice enough to send me an exchange unit right away after discussing the matter with Native Instruments. The second unit however has the same problem on a different pad.

I don’t have the budget to buy a “pro” unit.
Any suggestions on what to do? I think I could get a 3rd replacement unit, but if there’s something that’s better than the Maschine Mikro (in more or less that price range), I’d go for that.

Is that “normal” that these pad controllers have sensitivity issues? I watched Rob’s YouTube videos and those recommendations led me to the Maschine Mikro. I’ve also seen the video about the different Launchpad controllers, but two units with problems make me wonder if I’m doing something wrong…

Please let me know if you also had problems with pad sensitivity and how you resolved those.

1 Like

Hi Mathias,

I did have similar stability issues with Maschine Mikro Mk3 as well. I had to reconnect USB every time I restarted my PC as Mikro came with “TouchError” and became unresponsive.

Sometimes during operation, it would get stuck with one or a few keys lit and stopped responding to any input, so I had to reconnect the USB cable.
I’ve checked firmware, tried different USB cables, turned off USB power saving for the internal USB hub, all without any luck.
It helped when I moved to the USB C connection on the PC. I used USB C to USB A adapter that came with my Android phone.
Also, I would suggest trying a different computer if that’s an option. Maschine Mikro works properly exclusively with USB C port on my PC, but it doesn’t have any issues running on every USB port on my old Dell laptop. It seems the device is quite picky about power delivery.
As for pad sensitivity, one of my pads (right snare according to Q4G layout) is a little bit lazy. I had to hit it harder than other pads, and sometimes it didn’t trigger. I’ve increased pad sensitivity for that pad. Now it seems to be better.
Good luck with your Maschine. Let us know if you’ll be able to resolve your issues.

1 Like

I never got the message on the screen. The pad just hangs or stays lit.
I use an older MacBook Pro and can connect USB without a USB-C adapter.

Hey Mathias,

I sometimes get a pad on my maschines that stays “colored” after hitting it and then not touching it. This goes away when I touch the pad again. It never gets stuck forever.

Have you gone into controller editor and disable aftertouch for all the pads? That sometimes solves problems like these. Aftertouch isnt something you need when drumming and it sends a lot of extra signals to the computer, increasing the chance of overload.

Let me know if this helped!!

Unfortunately, it did not.
I’ll contact the store tomorrow and see if they’ll send me a third unit as a replacement. The pad sometimes doesn’t trigger, even if I press it hard.
Thanks for your help - it does make sense to deactivate the “press” midi statements regardless.

1 Like

Sorry to hear this. It’s not an issue I’ve ever heard of before. You could try one more thing: Install and plug it into another computer. Of a friend or something. Then you can determine if its maybe something like the “power saving” mode of the laptop cutting power to the usb outputs. Weird stuff like that happens sometimes, especially in laptops.

I’ve sent both controllers back to the store. Let’s see if they give me a third one as a replacement. It would be weird to have just one pad that’s stuck (different pads on the two controllers) because of power issues, but if Maschine number three comes in and also fails, I’ll try it on another computer.

1 Like


I have the exact same problem with the exact same pad on my Mikro 3 (the right snare). How did you increase the sensitivity, exactly?

Edit: I’m playing around the the Pad Velocity Curve in the Controller Editor now. The “Hard 3” setting helps a lot, allows me to do ghost notes on all the pads way easier. Gotta hit them a lot harder to hit 127, of course, but that’s probably a good thing. I think I’d rather be ultra sensitive like this.

1 Like

FYI - I got a third device as a replacement which seems to be working fine - so far :slight_smile:

1 Like

Mkay… interesting. Keep me posted and let us know if this changes!

I have also had an issue where a pad on my Maschine Mikro MK3 remains lit. Whenever this happens I am still able to play, so it’s purely a cosmetic problem at the moment, but it will remain lit until disconnected or I restart my PC.

What I have noticed is, thus far, this seem to only occur if I have left my Mikro idle for a short period (5-10 minutes or so) before returning to practice.

I’m using a Windows 10 PC and this will happen occasionally while running Addictive Drums 2. I also practice with Melodics but have never had this problem there. So, for me, the common factors seem to be: Addictive Drums 2 and my Mikro being left idle.

I hope this contributes something; I know OP is using a Mac, while I’m on Windows, and their latest Mikro seems to be working fine.

1 Like

Alright, very interesting. These types of problems are so weird… Sometimes they’re not there and then after a BIOS update or something… bam, weird stuff. I have an XPS15 laptop that’s 3 years old. Worked perfectly for real time playing and now it just craps out for a few seconds every 2 minutes. It’s fine for recording because I can just cut that, but a live playthrough is impossible right now.

I’m buying the XPS17 next month probably. I’m guessing the issue will resolve with that machine.

1 Like

About a week and a half ago I posted that I had a problem with pads on my Mikro MK3 remaining lit. Well now I have a different problem.:frowning:

I’ve finished the beginner course and I’m currently on Grooving & Improving. Because of my n00b status, I haven’t regularly been using all the pads. Pad 12 is set to “Ride” using the QFG pad layout, and it’s only now, with “Grooving & Improving” that it’s been getting used.

It you hit the pad itself, everything is fine, but if you hit it after playing any sequence of other pads it will randomly not register: The “Ride” won’t sound and the pad won’t light. Also, on the “Native Instruments Controller Editor”, and at the top right where it says “In” and “Out”, it will fail to register “Out” with every hit that does not count on the pad.

This has been going on for several days. I’ve tried different USB cables, a powered USB hub, USB C. I’ve made sure everything on my PC is up to date.

I’m in contact with Native Instruments support and I have a ticket, so I shall have to see what they say. Below is a short video of the problem for anyone interested.

1 Like

I had a problem similar to that with my bigger maschine mk3, but this got resolved with a firmware update. It was with the same pad combo, that ride and the kick. So that cannot be a coincidence. You got the latest firmware right? EDIT: you must have, because otherwise you couldn’t use controller editor…

Just to be sure:

Look for: [Firmware Updater for Maschine Mikro MK3

Where do you live? I’m tempted to send you my maschine mikro mk3 that I know works just to see if it also works for you.

1 Like

Thanks for the reply! I really appreciate the offer,:pray:, but I’m in Glasgow, Scotland. Besides, I have a ticket with NI and am awaiting their response, so this may or may not be resolved quite quickly. That, and I also have an Akai MPD218 I can use in the meantime. The pad sensitivity is dreadful compared to my Maschine, but at least I’m still able to practice.:+1:

It’s interesting that you had issues with the same pad combo. This gives me some confidence this can be resolved.

I have the latest firmware; already got the updater. Thanks for the link, but this was a step I tried after searching the net for possible solutions.

1 Like

Guys I was planning (fully convinced) to ‘upgrade’ from the MPD218 to a Mikro MK3 but I’m a bit scared now

1 Like

My Mikro MK3 experienced the lights turning off problem a single time only since I’ve had it, and I never had this issue where some of the pads completely stopped responding. I have to assume that this was some manufacturing defect that affected a certain batch of these units, but not all. It doesn’t seem to be systemic to all of the Mikro MK3s.

As always with this stuff, if you buy one, try to get it from a place with a good return policy…

@dArNb, have you heard from NI about it yet? Are they going to send you a new unit?

1 Like

My ticket was passed from support to the hardware team yesterday.

This morning I heard back from them, saying:

unfortunately this is very probably a hardware issue and the device needs to be repaired or replaced in our Repair Centre.

As per their request, I’ve sent them a copy of the purchase invoice, device ID, and my location.

They ended by saying:

After we receive that information from you, we can start to work on your case. Please do not return any devices before you have explicitly received authorization and instructions for returning.

And so this is where I’m at.

Well I hope they do you right and don’t make you jump through a million hoops.

It’s a good beatpad if you don’t have this issue, so I think it’s worth it to go through their process and try to get one that works properly. Doesn’t make it any less annoying, though :expressionless:

1 Like

Thanks. I’ll just need to wait and see. It’s been taking a working day for each reply, but NI haven’t been difficult to deal with so far. Hopefully I’ll get some good news tomorrow.

I’ll give updates as this progresses.